Spring naar bijdragen
Ellino

Stapeltellen ?

Aanbevolen berichten

De voor de vakantiegangers...

 

duitsland: Quersumme is stapeltellen

Deel dit bericht


Link naar bericht
Deel via andere websites

Vooral als het een lang getal is, tel jij je suf.

Volgens mij kan het ook makkelijker met de functie REST in MS-Excel.

Als je het deelt door 9 houd je een restgetal over.

 

Bijvoorbeeld : 123456

1 + 2 + 3 + 4 + 5 + 6 = 21

2 + 1 = 3

 

=REST(123456;9)= 3

 

:)

 

Geotrail

Even een kleine aanvulling... als stapeltellen op "9" eindigt, zie je in je formule "0"... :)

Dus voor GC2H054 (daar heb ik 'm nu nodig) heb ik het volgende uitgepuzzeld (K9 is het veld met de telling):

 

=ALS(REST(K9,9)=0,9,REST(K9,9))

 

vwewah

(voor wie er wat aan heeft)

 

Een kleine uitbreiding van de formule lost ook dit probleem op.

 

=ALS(REST(B1;9)=0;9;(REST(B1;9)))

 

Waarbij B1 de cel is waar het te stapeltellen getal in staat.

 

Zompies

Deel dit bericht


Link naar bericht
Deel via andere websites

Een kleine uitbreiding van de formule lost ook dit probleem op.

 

=ALS(REST(B1;9)=0;9;(REST(B1;9)))

Dan voer je vrijwel altijd twee keer een deling uit, dat is een dure operatie. Beter is:

=REST(B1-1;9)+1

Optellen en aftrekken is relatief goedkoop, en de formule is ook nog een stuk korter.

 

Tc

Deel dit bericht


Link naar bericht
Deel via andere websites

De voor de vakantiegangers...

 

duitsland: Quersumme is stapeltellen

 

Wees voorzichtig.

"Quersumme" betekend een keer optellen, maar niet "doortellen".

 

"Quersumme" = 1234 = 1+2+3+4 = 10 en klaar

"Quersumme bis zu einer einstelligen Zahl" = 1+2+3+4 = 10 = 1 + 0 = 1

 

Men moet dus heel nauwkeurig op de uitleg in de listing letten.

Deel dit bericht


Link naar bericht
Deel via andere websites

[...] Je kunt elke keer als je 9 tegenkomt deze meteen weglaten

en elke keer als je boven de 10 komt meteen stapeltellen

 

dus 123456 -> 3+6=9 weglaten, 4+5=9 weglaten, 1+2=3

of 123456=1+2+3+4=10=1 +5+6=12=3

 

En als je 852.148 moet stapeltellen, zie je misschien direct dat 852 + 148 = 1000 --> 1

Dat kan dus ook. Net als bijvoorbeeld 85 + 21 + 48.

Maar eerst cijfers wegstrepen die samen 9 maken, is inderdaad erg handig.

In mijn voorbeeld hou je dan alleen 2 + 8 over.

(En als je zo niets meer overhoudt, dan is het antwoord 9.)

Deel dit bericht


Link naar bericht
Deel via andere websites

Het voorbeeld 915 kan ook als volgt uitgelegd worden. Het cijfer 9 en combinaties van cijfers die samen opgeteld 9 opleveren doen niet mee. Vroeger was dit onderdeel van de zogenoemde 9-proef.

Voorbeelden:

9 + 1 + 5 = 15; 1 + 5 = 6

1 + 5 = 6

 

2458 geeft als stapeltelling 1

2 + 4 + 5 + 8 = 19; 1 + 9 = 10; 1 + 0 = 1

Sneller gaat, 4 + 5 = 9, doet dus verder niet mee

2 + 8 = 10; 1 + 0 = 1

 

 

Deel dit bericht


Link naar bericht
Deel via andere websites
19 minuten geleden zei HOOGGEACHTE01:

Wat als stapeltellen met negatief saldo 

Vb (21-24) (19-9). (17+10-16) 1o-19+4)(19-28-7)????

Welkom op het forum, HOOGGEACHTE01,

Stapeltellen kan nooit resulteren in een negatief saldo. Het voorbeeld dat je hierboven laat zien is er een van een formule waarmee je een coördinaat kunt samenstellen.

In dat geval zou ik het eerste denken aan de mogelijkheid dat ik een fout kan hebben gemaakt, en zou ik e.e.a. nog een keer checken.

Deel dit bericht


Link naar bericht
Deel via andere websites

misschien gewoon beginnen met een mooie tradie cache in een bos, voordat je aan deze slecht gemaakte cache, dus (onzin*) begint HOOGGEACHTE01

Barny

*(die dit niet mag zeggen) 
 

Deel dit bericht


Link naar bericht
Deel via andere websites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gast
Antwoord op deze discussie...

×   Plakken als rijke tekst.   In plaats daarvan plakken als platte tekst

  Er zijn maximaal 75 emoticons toegestaan.

×   Je link is automatisch geïntegreerd.   In plaats daarvan als link tonen

×   Je voorgaande bijdrage is hersteld.   Tekstverwerker leegmaken

×   Je kunt afbeeldingen niet direct plakken. Upload of voeg afbeeldingen in vanaf URL.


  • Onlangs hier   0 leden

    Er kijken geen geregistreerde gebruikers naar deze pagina.

×
×
  • Nieuwe aanmaken...